G oog le Buell 1125R Forum | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » 1125R Superbike Board » Archive through May 31, 2015 » Seems Slugish « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Shawns
Posted on Friday, May 08, 2015 - 04:37 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Could be just me, or not. Breaks up or cuts out like a rev limiter at about 7k. First time out riding due to health issues. Just doesn't seem the same. EBR race ecm with a keda rt3 exhaust. Did new plugs at the end of last season.
Top of pagePrevious messageNext messageBottom of page Link to this message

D_adams
Posted on Friday, May 08, 2015 - 05:28 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Should pull like mad to 10500 rpm or better. Charge the battery to full, possibly clean the injectors.
Top of pagePrevious messageNext messageBottom of page Link to this message

Shawns
Posted on Friday, May 08, 2015 - 05:35 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Ok, so it's not me. I'll try running some injector cleaner in the tank and see how she does. Battery seems fine, I always leave it on the tender when I park it for the night.
Top of pagePrevious messageNext messageBottom of page Link to this message

Shawns
Posted on Saturday, May 09, 2015 - 08:47 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Any particular injector cleaner used over another? It only breaks up under a load when riding, i can rev it when not in gear and it's fine. Could it be a clutch issue
Top of pagePrevious messageNext messageBottom of page Link to this message

Dannybuell
Posted on Sunday, May 10, 2015 - 01:07 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

If it was the clutch slipping you would be over revving and not going any faster.
Top of pagePrevious messageNext messageBottom of page Link to this message

Zac4mac
Posted on Sunday, May 10, 2015 - 01:40 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

OK, not plugs... my first choice.
Check that coils are tightly screwed to the valve covers and electrical connectors well seated.

A remote possibility, sweep your bars side to side and make sure neck wiring is good.

Causes for breakup at high rpm usually - spark failure at higher pressure(nope), reversion(no breathing/fueling changes, unlikely) and electrical/signal loss from vibrations - likely.

My 2
Z
Top of pagePrevious messageNext messageBottom of page Link to this message

Shawns
Posted on Sunday, May 10, 2015 - 07:10 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I'll have to check the coil connections. I don't have an ignition switch, I changed it to rfid.
Top of pagePrevious messageNext messageBottom of page Link to this message

Thefleshrocket
Posted on Monday, May 11, 2015 - 05:17 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Make sure your battery terminals are TIGHT. Mine were snug but not tight and I had issues starting and the bike was less-smooth than expected at higher RPM. I got the terminals good and tight (used a socket instead of a screwdriver) and that made it much better.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration