G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » THUMPer Forum  


Buell Blast Forum - Buell Blast Motorcycles - Buell Blast Discussion



Welcome to the Buell Blast Forum aka the "THUMPer Forum".

For Buell Blast P3 American Thumper-Cycle related questions, technical discussions, and information. Come on in and get some THUMP! : ]

Owner's Manual
application/pdf
Blast Owner's Manual .pdf (590.9 k)

EZ

Got THUMP?


THUMPer Forum: The Buell Blast Forum on BadWeB (for Buell enthusiasts)



to store and compare Blast fuel economy.

Please feel free to add your data to the database. It's very easy and lets you track your mileage and compare to all other Blasts in the database. Please use your forum name when you enter your data.

This is a link to the Blast MPG Data Page

This is a link to the data entry form


Bookmark the form for ease of use.

Enjoy!


Please Note!!!!!!
We are in no way responsible for any damage that may occur in the advice given to help you fix or 'improve' your bike. We are here to try and help, but that does not make us libel for any actions resulting in that advice, you could easily go elsewhere and ask for other opinions, and act accordingly.
Thank you for understanding.

Just cuz - Manuals -
http://buellmods.com
EZ

  Thread Last Poster Posts Pages Last Post
Questions from New Buell Blast Riders - ThumperFAQMonzaracer1242 61 10-05-16  03:45 pm
BLASTARDS ARE WE
Who we are and what makes us tick!
Please feel free to add to the list!
Gearheaderiko493 18 02-27-17  01:08 pm
Got Thump? (Buell Blast Photos)
For sharing photos of Buell Blast Motorcycles (Thumpers in the House)
Ezblast3313 112 03-17-17  02:30 am
Buell Blast Thumper Knowledge Vault
From Carbs to Customizing to High Performance & Racing - All the tech & tricks for Buell Blast Motorcycles, find advice & answers here - or post your questions!
Gearheaderiko26129 1507 09-19-17  12:33 am
Blasting Away - The Thumper Quick board
For unique exploration of ideas involving our Thumper!
Gearheaderiko7106 694 05-29-17  11:55 am
Buell Blast Racing!(and track days)Ezblast999 39 06-13-15  05:47 am
Thumper Tales (Tales From the Darkside!)
Ride Reports, Tales of Adventure, "Blasting on the Dark Side", & other stories of Buell Blast Thumpercycling.
Ezblast1845 67 09-02-17  02:02 am
Buell Blast Recalls, Tech Bulletins, Notices, & Concerns
The Buell BLAST! is a great motorcycle, however no bike is perfect - here is a place to post official recalls, tech bulletins, notices, and concerns related to the Buell Blast.
Anthony0267227 06-16-16  09:04 am
Blasting Around (Buell Blast Riding Groups)
Local and regional forums for meeting, greeting, and riding with fellow Buell Blasters (Thumpaholics)
Xb9er596 100 01-12-17  06:02 am
Pay It Forward: Blasting Goodness! (Trades Welcome!)
Pay It Forward - Buell Blast Parts & Gear: For assistance or to help your fellow Buell Blast riders when in need.



Kennyd331 14 06-14-16  05:13 pm
Buell Blast Motorcycle Classifieds...
Buell Blast Motorcycles, Parts, Gear, Accessories - For Sale or Wanted
Marksblast2646 555 08-16-17  05:47 pm
Blastphemy!
For non Buell discussions, questions or pictures that do not pertain to Buell.
Court424 14 03-05-17  06:51 pm
ArchivesEzblast16100 552 03-15-14  05:08 pm
Archive through June 01, 2017Slideways30 06-01-17  05:26 am
Archive through February 04, 2017Ezblast30 02-04-17  01:29 am
Archive through November 06, 2016Ezblast30 11-06-16  02:09 am
Archive through September 08, 2016Blastjedi30 09-08-16  02:04 pm
Archive through July 29, 2016Odd30 07-29-16  11:34 am
Archive through June 14, 2016Jetlee30 06-14-16  01:15 am
Archive through May 02, 2016Gearheaderiko30 05-02-16  11:29 am
Archive through April 09, 2016Gearheaderiko30 04-09-16  09:27 am
Archive through March 08, 2016Copper130 03-08-16  03:56 pm
Archive through December 18, 2015Gearheaderiko30 12-18-15  01:51 pm
Archive through September 22, 2015Chipmyers30 09-22-15  09:02 am
Archive through September 09, 2015Gearheaderiko30 09-09-15  01:01 pm
Archive through July 14, 2015Th3wizard30 07-14-15  12:29 pm
Archive through June 24, 2015Gearheaderiko30 06-24-15  07:47 am
Archive through June 06, 2015Gearheaderiko30 06-06-15  09:31 pm
Archive through May 20, 2015Gashaw4030 05-20-15  06:11 pm
Archive through April 28, 2015Marksblast30 04-28-15  09:46 pm
Archive through April 10, 2015Ezblast30 04-10-15  06:46 pm
Archive through April 01, 2015Chief_ten_bears30 04-01-15  12:17 pm
Archive through February 21, 2015Ezblast30 02-21-15  02:37 pm
Archive through December 23, 2014Ezblast30 12-23-14  12:47 am
Archive through October 08, 2014Ezblast30 10-08-14  11:10 pm
Archive through September 14, 2014Marksblast30 09-14-14  09:30 pm
Archive through August 10, 2014Ezblast30 08-10-14  02:30 am
Archive through July 05, 2014Gearheaderiko30 07-05-14  09:12 am
Archive through June 04, 2014Ezblast30 06-04-14  04:04 am
Archive through April 22, 2014Ezblast30 04-22-14  01:21 am
Archive through April 10, 2014Uneasy_rider30 04-10-14  11:16 pm
         

Please visit the "Got Thump?" section for pics of various Buell Blasts; check out our "Knowledge Vault" for Buell Blast technical questions, look in "Blasting Around" to find who is in your area for rides and "hi!"'s; visit "Blasting Away" to see unique ideas involving the Blast, and visit the "Dark Side" for tales of Blasting adventure! Post at the bottom of the page here for anything else or just to say hi! Welcome and enjoy! : )

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Slideways
Posted on Thursday, June 01, 2017 - 05:26 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

If you use a a Harley CV carb and the timing is controlled by the TPS will it run at All? How can you mess up the TPS? You take it off, there is a little black part that connects to the throttle shaft. It seems foolproof. Is there an adjustable idle mixture screw on this Carb? The carb boot is coming, a #45 jet can be picked up at the local Harley shop. It has been on you tube on how to adjust the enricher so that it runs richer. May put a vacuum gauge on it to see what's up. Timing and valves should be on the money at 245 miles. All the carb passageways blew out nicely. All the gunky stuff appears to be cleaned out of the carb. Above idle it runs great, pulls hard at WOT. Fun feeling scoot.
I look forward to seeing how the new parts and adjustments help out. Bike is in great shape and the owner needs to get in some good road smiles.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Thursday, June 01, 2017 - 04:36 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Timing just defaults to WOT. TPS doesn't control timing, just the timing advance curves (just like a VOES switch on all other carb'd harleys). It's not high tech.
AE is the same as a choke on regular CV carbs. It's just doesn't have a manual control (just heated Electrically).
TPS might seem foolproof, but apparently its adjustable.
I haven't run the AE or TPS in many years. All my engines wound up on the racetrack and the Blast carb wasn't suited for it.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Thursday, June 01, 2017 - 04:38 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Since you seem knowledgeable, I'd be more comfortable with you fixing the Blast carb, than someone inexperienced.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Thursday, June 01, 2017 - 06:39 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

PS I've seen some great stuff on YouTube and some really really bad Blast stuff on YouTube!

That's basically just a general warning!!
Top of pagePrevious messageNext messageBottom of page Link to this message

Slideways
Posted on Saturday, June 03, 2017 - 11:06 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Got it running. Slow jet 45, .
Drilled the idle mixture blocker and turned out 2 1/2 turns. The enricher was already wide open so didn't touch that. New boot. Had to hand choke (cover air horn to get gas to draw into throat of carb) it to get it to start cold. Backfired a fair amount when first started. Tighten boot clamps even more and that stopped. Test drive went well. Idles great. Starts great when warm. Look forward to cold start report. Fingers crossed, we will see.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Saturday, June 03, 2017 - 06:59 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)


Thanks for keeping us posted.
Top of pagePrevious messageNext messageBottom of page Link to this message

Slideways
Posted on Sunday, June 04, 2017 - 02:47 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

OK it takes 5 minutes cranking to start cold. I need the auto enricher flow chart. I need to see if gas is being drawn up to the enricher chamber. Its a straight shot from enricher chamber to the throttle bore. I need to make sure I have good flow from from the float bowl to the enrichment chamber. When I hand choked it it drew plenty of fuel. I appreciate any advice on how to make the choke work better. I said earlier that the enricher was wide open. I think Im gainin on it gang. Thanks for the advice.
Top of pagePrevious messageNext messageBottom of page Link to this message

Jen_courtney
Posted on Thursday, June 08, 2017 - 08:40 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)


Okay I'm new both to this group as well as to riding on the street so hello anyone that is reading this and please be kind.

2006 Buell Blast 2400 mileage
Just bought this bike and was having trouble getting it to start. My neighbor cleaned out the carb about a week ago. I took it for a short ride and just as I pulled onto my road and went to downshift the bike went into neutral but would not go back into gear. At that time the idle did surge for a minute. I shut it off and another neighbor came out and was able to get it into gear and to my house. After this I figured out that it would start by giving the throttle 4 pulls and then open it completely up while starting it. It seemed fine for a couple more very short rides but yesterday I when I started it up it was grinding as I went to put it in 1st gear. I tried 2nd and the same thing. Finally it went into gear and from 1st to 2nd fine. I put it in neutral when I got to the stop sign and was unable to get it back into gear. I ended up asking yet a 3rd neighbor to help me push it back to my house (as I can only push it while sitting on it due to my size and strength.). I do remember right before taking off that the clutch didn't seem to feel like it normally does.). An hour later a friend went to my house to rethread the shifter toe peg. He was gone by the time I got back but didn't have the key anyway. Yet another guy friend of mine came down to see my bike but this time it wouldn't start.

Since it seems that as soon as I bought this bike all of my guy friends are suddenly expert HD mechanics who never do anything but losen bolts or whatever and leave things off while taking their tools with them, I've decided that I no longer want any of them working on my bike. I need to learn this for myself. I am begging for the advice of all of you who I hope better understand Buell Blast issues.



The issues:
It cranks but I'm guessing that either it's flooded or possibly not getting fuel? When I first took it out (after dumping all of the gas out including 2 cans of sea foam that the "new HD mechanics" had dumped in then replacing it with high obtain fuel.) I realized I'd accidentally been on reserve. Since this bike is an '06 with only 2400 miles on it, it's crossed my mind that the bottom of the tank may have had sludge that got sucked into the reserve line. At any rate it doesn't start now with the gas on.

Issue 2: It's not shifting into 1st or 2nd gear (pulling in the clutch.) There were soooo many things online about this but mostly only in higher gears.

I did buy oil, a spark plug, an oil filter and a gasket that my neighbor said I needed that goes between the carb and the air filter.

* I did add a little bit of oil to it and ran it a few mins an hour before it wouldn't start this last time. It is just a little bit above the line on the dipstick but not much.

Please help me figure out where to start. I'm getting buried financially with my harem of "mechanics" (who I figure want to get me to hang out under the guise of "helping").

Thanks,
Jen Courtney

Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Friday, June 09, 2017 - 01:21 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Welcome Jen!

First: the Blast is and is not a Harley. Many Harley guys (professional and non professional) don't know the difference with this bike and often foul things up.

Second: shifting into 1st and 2nd gears is often a problem on this bike. Causes: loose shifter, too tight primary chain, too high an idle, improperly adjusted clutch. If it's a used "Riders Edge" bike if often due to abuse.
Make sure the shifter is tight.
HAs the primary chain been adjusted? If it has, it's probavly too tight as the repair manual is wrong in adjusting specs.

Third: STOP taking the carb apart. If someone tells you "it needs a good cleaning" it translates to "I have NO IDEA what's wrong and I hope this helps". It rarely does and VERY OFTEN causes more problems.
The auto enrichener (or choke) is probably not working very well, probably from sitting. The slow jet in the carb needs to be replaced with a #45 (common stock Harley part) as its lean from the factory. This often cures hard starting or at least makes a marked improvement.

We'll need to take it slow. At 2400 miles it's still brand new and there should be NOTHING wrong with it. Stop changing parts and let's find the problems first. Then if you want to change parts you won't be messing anythjng more up. But let's solve one problem at a time.

Last but certainly not least "Das Boot" or the intake boot commonly fails. It might be bad already. Nonetheless, order a new one. At 11 years old you'll need one sooner or later. Get one now!

If you don't get a response here, feel free to pm me.
Top of pagePrevious messageNext messageBottom of page Link to this message

Slideways
Posted on Sunday, June 18, 2017 - 12:07 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

The hard cold starting blast has been solved. The choke fuel enrichment jet was never drilled. NO fuel was going into the enrichment chamber. NONE. I drilled it and it starts now. It may be getting a little too much fuel now. Have adjusted the enricher so that it's not as open cold. You have to hold the throttle open a little for 45 seconds and then it idles fine. I may adjust the enricher little more closed to see how that works. Any body ever had an undrilled Carb? I have not. Owner rode bike to fill with up tank. He liked the ride. Thanks y'all.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Sunday, June 18, 2017 - 12:29 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Interesting. But I wonder how it ever started when cold? I would say "how did it ever pass final inspection before being released to the customer?", but I know the Blast was very low on the 'givashit' list and many dealers were just happy to see them leave (hopefully not to return).
Top of pagePrevious messageNext messageBottom of page Link to this message

Slideways
Posted on Sunday, June 18, 2017 - 08:43 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

2004, 240 miles, 3 owners. It only ever started with help or luck a little fuel dribbled in from a jet or two from constant cranking. This was amazing.
Top of pagePrevious messageNext messageBottom of page Link to this message

Oldblastrider
Posted on Thursday, June 22, 2017 - 04:40 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Is Buell riders online offline?
Top of pagePrevious messageNext messageBottom of page Link to this message

Jmoe515
Posted on Wednesday, June 28, 2017 - 10:44 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Did a lot of work on it over the winter. New custom sportster style tank, exhaust, paint and EFI!


Buell


buell


Buell


Buell


Buell


Buell
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Wednesday, June 28, 2017 - 11:27 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

VERY NICE!!
Top of pagePrevious messageNext messageBottom of page Link to this message

Hybridmomentspass
Posted on Thursday, June 29, 2017 - 07:43 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Interesting mods, any power improvement?

But, dang, that looks like a rats nest of wires and cables! Hard for me to take in the whole bike because my eyes go to that mess
Top of pagePrevious messageNext messageBottom of page Link to this message

Ahampton128
Posted on Sunday, July 02, 2017 - 07:05 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I'd love fuel injection on my Blast...
Top of pagePrevious messageNext messageBottom of page Link to this message

Benjaja
Posted on Monday, July 17, 2017 - 12:38 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hello Im a new to motorcycles and bought a 2001 Buell blast which has been still since before I went to college and moved.

Last time it ran was in 2010 and it leaked oil something wicked. It leaked from up top as far as I can tell.

I've pressure washed it so once I start working I can further tell where it's leaking.

Should I be replacing all the gaskets at this point? Rocker Cover, Rocker arm to Cylinder head gasket, crankcase ventilator grommet, push rod tube? Anything else that you'd suggest? Im trying to do this cheaply so will be doing all the work myself any my brothers who are mechanically skilled with bikes

I know Ill also need a new battery and belt
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Monday, July 17, 2017 - 02:48 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

How many miles on the bike? Was it stored inside?
Just the rocker cover gaskets and PCV grommet. Don't pull the cylinder head.
Replacing the belt probably isn't necessary, but if you do, keep the old belt as a spare.
Order a new intake boot "just in case".
Do Not take the carb apart "to give it a good cleaning". If it has a running problem, it's probably a clogged slow jet. Go buy a new #45 slow jet-about $6-$10, stock on many Harleys before they went to fuel injection.

Just ride it before you start replacing parts 'willy nilly' and see what it needs. If you just start replacing parts just for the sake of replacement, you're much more likely to run into problems.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Monday, July 17, 2017 - 02:52 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

PS An oil change with filter takes 1 3/4qts and it be FULL!! Change it when it's hot or at least been ridden for 10 minutes. Oil capacity is 2.25qts TOTAL-that's if you get every last bit of oil out of it-which you won't with a normal oil change.
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Tuesday, August 08, 2017 - 12:38 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)




And now something different - Romania strikes again - or should he be called "Chicago" now?
Anyway - once again a great rendition!
EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Odd
Posted on Wednesday, August 30, 2017 - 01:14 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

After shifting into first when releasing the clutch I'm getting a good klung . I'm guessing bad gears? Help
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Wednesday, August 30, 2017 - 06:31 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

When releasing the clutch? If so, could be the shifter pawl is out of adjustment. Unless the bike is high mileage or has been abused, the gears are probably fine. You should make sure all clutch and chain adjustments are good as well as using the correct trans fluid filled to correct amount.
Top of pagePrevious messageNext messageBottom of page Link to this message

Odd
Posted on Wednesday, August 30, 2017 - 10:15 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

yea when releasing the clutch,sometimes if you release the clutch half way to kind of preload there is no knock. low milage but it was a riders edge bike.I'll check the shifter pawl first.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Wednesday, September 06, 2017 - 12:19 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

$49 shipped!!!!
Pirelli MT75 rear tire
https://www.ebay.com/itm/382178503162
Top of pagePrevious messageNext messageBottom of page Link to this message

Vsingle
Posted on Wednesday, September 06, 2017 - 10:41 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks for the heads-up on the rear-tire ebay deal. Gunna give em a shot, only hope they aren't 5 years old.
Top of pagePrevious messageNext messageBottom of page Link to this message

Crackhead
Posted on Friday, September 08, 2017 - 12:27 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Alright, I am finally getting the back on the bike again after having my gallbladder removed. And I'm having some problems.

First the bike wouldn't start, assuming it was old gas, (6 months almost) I dropped the bowl and also noticed the screw clamp folding the carb to the boot was loose.

Now, it will start most of the time, but the RPMs hang when I let off the throttle. That would be from a vac leak right?
Top of pagePrevious messageNext messageBottom of page Link to this message

Crackhead
Posted on Friday, September 08, 2017 - 01:43 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

humm, so i sprayed carb cleaner all around the boot and where the intake tube bolts to the head, no real change in RPMs. It should be a quick spike right?

I have also replaced the boot.

(Message edited by crackhead on September 08, 2017)
Top of pagePrevious messageNext messageBottom of page Link to this message

Torquehd
Posted on Tuesday, September 12, 2017 - 10:15 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Crackle vacuum leaks on (HD) style carbs don't usually produce lingering rpms. Can you observe on the carb that the throttle plate is snapping back all the way closed? I'm wondering if your throttle cables might need lubed.
they recommend spraying soapy water to find intake leaks. But brake parts cleaner or carb cleaner can work. It can make the rpm's surge or it can about kill the motor but it's almost always a noticeable, reproduceable change. As in, every time I squirt this part of the intake manifold it does it.

Lingering revs could also be an enrichener problem but it's been a hot minute since I've remembered how the auto enrichener works.
I miss the pushrod and carb simplicity of the blast.
 

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration