G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Troubleshooting (Poor Starting/Running/Handling/Ride Issues) » Archive through May 25, 2007 » Speedometer quit working! « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Jester8609
Posted on Thursday, April 12, 2007 - 01:32 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only)

i have a 02 buell cyclone and the other day the speedometer started acting funny like sticking at 30 mph then started working again then next time i looked nothing. its been a week and its not working. any help would be appreciated.

thanks, jester}
Top of pagePrevious messageNext messageBottom of page Link to this message

Reepicheep
Posted on Thursday, April 12, 2007 - 03:26 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only)

It's a fairly chronic problem on the tubers. It's the speedo sensor, that bolts into the top of your crankcase towards the back (shifter side).

Pull it and remove the metal fuzz (its magnetic), and put it back in. If you are lucky, it will then work again, but it probably won't, the sensor is probably blown.

The updated factory part should solve the problem. If you come across an old part, we can make it safe to use, but it takes a little hardware hacking.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gunslinger
Posted on Friday, April 20, 2007 - 09:46 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only)

I had the same thing happen a few years ago. It's not a big deal. Its a standard part you can get at any Harley dealer, and they will most likely have one in stock. They cost about $25 and changing it out takes just a few minutes.

The vibration isolation of the uni-planar system works quite well at keeping the vibes from the rider. The down side is that the engine and anything attached to it vibrates like crazy. Than accounts for a lot of the electrical gremlins tube frame Buells are prone to.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration