G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » XBoard » Beginning of My Most Difficult Project: XB9R to 12R Thunderbolt Swap « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Sunday, August 23, 2020 - 10:49 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hello BadWeB'ers!

I have been a long-time member of this forum, but not a recent user. My desire to start this thread came out of a realization that I am most likely in over my head on a project started in 2010. Now having found myself in a better position to continue/finish this project, I will share my experience via the forum in hopes that the therapeutic effects of writing on my suffering, and most importantly the expertise you all share, will somehow assist my endeavor to finish the bike. I’ll start with the back story and apologize in advance for my wordy writing:

I have had this 2003 XB9R since 2008 and absolutely love the bike. I did a few mods from then till 2010 which included carbon fiber body work, full micron exhaust and an assortment of parts from the former AmericanSportBike.com (American Sport Bike). In 2010 I took some time off to go on a long ride up the PCH with a buddy. During that ride the motor began knocking then died. After draining the oil I found a large amount of metal debris and silver coloring. Through research I learned the oil pump drive gear in ’03 XBs had metallurgical issues and attributed this defect as the culprit to blown motor What will I do? My solution: well, motor swap of course! Why not take a relatively inexpensive bike and throw a ton of money at it?

Anyhow, I went to work disassembling the bike and acquiring what I needed to swap in a 12. And this is probably when the mistakes started. My swap project took me in to 2011 when my work life changed, quite a bit. I had to move and was gone for almost two years for some military training. Then from 2013 to present I continued to deploy and move, not allowing me to set up and get back to my build. Slowly the Buell became an afterthought, until now.

My life has calmed down a bit and I’m ready to go at this and finish what I started. But, not having looked at the parts or work on the project for some time, I’ve lost documentation and pieces that will most likely be an issue. I welcome the forum’s input to my problems as I know the expertise can help get me on track.

Here is a list of issues I have uncovered:
-The motor: I’m pretty sure it’s a 2009, based on the following engine number: AX039300231. XBs made a few significant changes in 2008 which included introduction of the 12R “Thunderbolt” motor. I bought my current motor out of a wrecked bike with 1700 miles (had to search for the old Ebay confirmation on this).
-The heads: The motor had one head where the front isolator bolt had been ripped out, mostly likely from impact, so I bought another set of heads based on the part number. BUT….although the part number is the same; the new head cooling fins are machined (front head). The rear head fins which came with the motor are not machined. Looks a little funny and I’m hoping the machined edges are the only difference(s). In the back of my mind I worry I may have two different heads on the bike.
-ECM: So, 2003-2007 XBs have cam timing pickups. 2008-2011 have crank timing pickups. Sigh. When I bought my motor I also purchased a number of items from the wrecked bike: wiring harness, throttle body, assorted mounting hardware, etc. But I still need an ECM which will be able to properly pick up timing of the new motor. Hopefully I can get the ’09 harness to work but we will see…
-Engine and Trans Sprockets: So, I bought “upgrades” from American Sport Bike which included a 27 tooth trans (drive) sprocket and a different engine sprocket. The trans sprocket has a bit of surface rust and needs to be removed again, have the rust cleaned, then be inspected to see if the rust caused any lasting damage. I have an extra engine sprocket found in boxes and can’t remember if it’s the original or the new item from American Sport Bike. The current mounted engine sprocket is 5”, the loose (not mounted) item is 4 3/4”. Thinking about leaving it on as this isn’t a deal breaker to finish the project. And, what could go wrong?

Next Steps:
- Having the primary cover powder coated to cover some scratches.
-Possibly take the engine to a local San Diego bike shop to give it a once over after having sat for 10yrs.
-Begin assembly.

For those who are still reading, in 2011 I had made a lot of changes/upgrades to the bike as I removed the XB9R motor. Here is a list of all the upgrades I can remember:

-Thinner head gaskets from American Sport Bike which gave a small bump in compression.
-Five angle valve job (mostly polishing) by a bike shop in Phoenix who also mounted the new head.
-All Carbon fiber body work: low-cost stuff from Ebay (China).
-American Sport Bike intake upgrade
-Right side cooling scoop to direct air to rear cylinder and give something of a symmetrical look to the bike (from an XB lover in Belgium I met on this forum).
-Upgraded Race Tech fork springs and valves based on my bodyweight, built by a different shop in Phoenix.
-Fork tubes anodized black
-Upgraded Eibach rear shock spring installed (500lbs/in). I can provide full part number to anyone interested.
-Full Micron Exhaust. I don’t want to say what I paid for or went through to buy this unit from a very nice gentleman in Australia.
-New “upgraded” American Sport Bike belt tensioner.
-Black powder coating: wheels, frame, swing arm, anything that was silver is now black.
-GPR4 steering damper.
-There is more, I’m sure…

So, thanks for reading up to this point. I really encourage as much comments and feedbacks as folks have the time. I will be posting to this thread periodically, while the build progresses, seeking assistance. This week I’ll be looking for a local shop to help with the motor. I’ll let you guys know how that goes. Have a great day!
Top of pagePrevious messageNext messageBottom of page Link to this message

Xbpete
Posted on Wednesday, August 26, 2020 - 08:56 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Interesting project! Glad to see you got the harness, lotta changes and the 08 engine is solid. IDS sells a proper ECM for the 08, problem is the micron, I have one on my 12R, there are a couple tunes out on the interwebs but none I have used. My bike seems to have run fine for the last 15 years with the race tune I got from Buell and I am not into mapping, I have a Cr and Sx that are quicker and easier on my achin old back,, hope you keep the updates coming and some Pix... my 12R is getting a Cr/EBR front end as my latest project,,,

(Message edited by xbpete on August 26, 2020)
Top of pagePrevious messageNext messageBottom of page Link to this message

Xbpete
Posted on Wednesday, August 26, 2020 - 08:58 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)



Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Monday, August 31, 2020 - 12:43 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

XBPete,

Thanks for commenting! Yes, I need to add some pics but I'm still in the early stages of the project and trying to get organized. I felt a picture now would not capture much intrigue! Thank you for the recommendations on suppliers for an ECM. I will definitely look them up. I hope to just get a good base map and then find a tuner as I'm in SoCal and believe there are a number of options available . By the way, I LOVE that uppper triple tree clamp in your pic. Mind sharing the brand/manufacturer?

Update: Primary cover is coming back from powder coat this coming week. Had it coated again to cover up some scratches attributed to the donor bike's previous driving skills. I've got some of the mounting hardware (front & rear isolators, v-bracket, throttle body bracket) painted and bolted to the new motor.

The transmission pulley has rust and I feel i should pull it off, attempt to remove the rust then assess whether the pulley has been compromised. So, a 1 7/8" socket is on the way from Amazon to assist with this. I also looked up some hacks that would help me avoid buying the expensive removal tool from a dealer.

I spent some time disassembling the old harness so that I may mount the new harness. I was able to reconnect the ignition module directly to the ’08 harness As I did this, I came across some bad solder connections (by me a decade younger) which will need to be fixed. I identified a seized bolt in my fancy billet block off plates which cover the old mirror mounting points (I switched to bar end mirrors way back when). So began the fun of attempting to remove this seized bolt made of high quality steel. It wasn't fun and led to my culminating point for the weekend. Next weekend my patience should return. The bolt will lose its grip on my project, one way or another.

Some topics I need to research further: will my 2003 XB9R coil suffice or should i replace/upgrade to an item supporting my current setup? Will all of my 2003 forward control connectors mate up to the new(er) harness?

For those interested, I plan to continue updating my project and pain, and as always I welcome feedback. Pictures will be posted next week, I promise.
Top of pagePrevious messageNext messageBottom of page Link to this message

Puc_it
Posted on Thursday, September 03, 2020 - 03:01 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I swapped a '09 motor into my '07 bike. XB12R. It is running great now but there were more differences than expected when I started. You're welcome to DM me if you want to chat. The wiring harness I ordered brand new. It shows up blank. The HD shop near me wasn't happy about messing with it but I did all the wrench turning and all they had to do was find a map to load onto it. They're back to being happy to work on it now that it's been running strong for a few years again. The bike is approaching 40K now. I think I need to calibrate the speedometer. It is hitting top speeds that I was never able to reach before and they don't match the speed on GoogleMaps app. The app matches when I'm in the SAAB. Yes, I have an affinity for vehicle brands that don't exist anymore. My last car was a Pontiac.
Top of pagePrevious messageNext messageBottom of page Link to this message

Phelan
Posted on Saturday, September 05, 2020 - 11:05 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Text me some pictures of all the parts you have and I can help you sort what from what. I've had 42 Buells and am somewhat an authority when it comes to swaps like this ; ) . 806 six eight one 8004.
Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Sunday, September 06, 2020 - 09:33 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks to Puc it and Phelan for responding to my posts. I'll be messaging you shortly with some questions.

Update: I have disassembled the old harness and am attempting to mark all connections for potential future use. But, I was not able to determine the function for the connector listed in my first two pictures. Does the forum have insight on what this is? My review of the wiring diagram wasn't productive.

I was not able to remove the transmission sprocket using the "hack" seen on some sportster forums. At this point I can just leave it on or buy the tool which holds the sprocket in place. Problem is, the tool seems expensive and none seem to be listed as compatible for my 27t sprocket from American Sport Bike way back when. I may just leave it on and if it chews up a belt, worry about things then.

My next purchase needs to be an ECM as I'm ready to fully mount the harness. I don't know if I should go with something new from IDS or an an ebay find and attempt to have it programmed (see link: https://www.ebay.com/itm/2009-BUELL-LIGHTNING-XB9SX-XB9S-XB-9-ECU-ECM-CDI-COMPUTER-BOX-CONTROL-OEM-0944/383054398185)

It is my impression that any 2008-2009 XB12 ECM will suffice due to the crank timing pick up vs 2003-2007 cam timing pick up.

Lastly, painted a few more pieces black to continue the the theme. Got the primary cover back from poweder coating. San Diego Powder Coatings may not be cheap but they do an outstanding job. Its easy to see the difference between a professional powder coat and my rattle can work. Thanks in advance to anyone willing to answer the above questions. Cheers!
Connector

Terminal






Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Monday, September 14, 2020 - 01:14 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Not much progress made this weekend. Primary cover and throttle body are on. Swingarm is loosely mounted. I was not able to locate my 7/8" axle nut in the tool kit so will need to order one of the tool set ups from St Paul HD or maybe try the large spark plug hack i've read about.

Much thanks to Robert, Ross (Pegasus Performance), BJ DeJong and lastly Tim at IDS for all their recent input. I have ordered an ECM from Tim which he believes will work best with my Micron set up and mild motor mods. BJ gave me a good idea on how to adapt my oil line fittings on the '03 swingarm to fit my '09 motor. I'll be shopping a hydraulic shop this week or look at some fancy AN fittings and go from there.

Below is a pic showing my slow progress. The saga continues....
Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Monday, September 14, 2020 - 01:15 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)



Top of pagePrevious messageNext messageBottom of page Link to this message

Ducbsa
Posted on Monday, September 14, 2020 - 06:04 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

For your nut, get a coupler nut with the right hex at Home Despot.
Top of pagePrevious messageNext messageBottom of page Link to this message

Claytonrides
Posted on Monday, September 21, 2020 - 01:22 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Good Evening Bad WeBbers!

I spent a fair amount of time on the project this weekend and have some updates. Short story, I welcome feedback from the forum on my questions (skip to the bottom to avoid my verbose nature).

First, Ducbsa thanks for the input. Wish I would have seen that earlier. But I realized my tool kit was missing a few items and a new tool kit from St Paul HD was only $30. So swing arm is now on, that was the easy part…

’09 wiring harness was mounted to the fairing support bracket with my fancy new ECM from IDS. I chose the Jardine tune as Tim felt this was the safest option for a base tune till further work can be done. No doubt Ill need to upgrade to one of his programmable models at some point in the future.

I attempted to test the harness to see if I could get it to power up. At this point my lack of experience became apparent. Thinking I could just hook up some positive and negative thermals to a battery I quickly learned this would be disastrous. After throwing more than a few sparks it came to my attention that I would need to fully attach the harness to its appropriate grounds (at the least) before testing. It was at this point I began to run through all my connectors.

Problem 1: It appears my crank position sensor (CKP) male connector (from harness) has been cut. I found the wires which match the wiring diagram from ’09.

Problem 2: The fuel pumps changed to some degree from 07 to 08 (as did many other components) and the fuel pump connector from my ’03 will not fit the corresponding harness connection. The fuel pumps are expensive to replace.

So here are my questions which need to be sorted:
-Should I just cut the CKP and connect it up with some typical electrical connections? There are just two wires for the sensor itself so it seems cost effective and simple relative to acquiring another harness or attempting to find the harness connector to splice in.

-Should I replace the fuel pump with the ’08 model or should I attempt to wire up my 03 pump? Replacing the pump would be contingent on its fitment to my 03 frame. A pump purchase my lead to a new fuel line purchase but I don’t know if there will be any tertiary effects.

-What would be the best bolt to function as my rear axle pinch bolt? I can’t find mine and wasn’t able to locate the right bolt in St Paul HD’s Buell site.

Here is my next phase of parts to buy:
-Swing arm pinch bolt(s)
-’09 Oil cooler (gonna upgrade)
-Spark plug to coil wires (these were changed in 08, but the coil part number remained the same)
-A few fastener trees
-Front isolator bolt (I seemed to have lost this)
-Throttle cable bracket

Thanks for reading this far. I welcome any responses and appreciate everyone’s input thus far.


« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration