G oog le Buell 1125R Forum | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » 1125R Superbike Board » Right cooling fan issue « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Sunday, June 06, 2021 - 01:13 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hey folks. Bought an 09 1125cr about a month ago. Went to spill and fill all the fluids and upon bleeding the coolant I realized the right cooling fan isn't kicking on while the bike is running. Left always comes on at 170. Right only kicks in for cooling fan interval after the key is turned off. Never runs while the key is on. I ran a bunch of tests and did the diagnostics described in the manual which led me to the conclusion that the ecu wasn't providing ground to the fan while the bike is running. I replaced the ecu and still getting the same result. Bike is not throwing any codes. The fan is always getting 12v. Can someone shed some light on this please?
Top of pagePrevious messageNext messageBottom of page Link to this message

Tribalreaper
Posted on Sunday, June 06, 2021 - 06:10 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Some were between 180 to 190 before the second fan kicks in on a 2008 1125r
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Sunday, June 06, 2021 - 09:50 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I thought that might be the case although I do not see any settings for individual fans in ECMdroid. I also let the bike get up to 190 degrees last time I ran it and still no action from the right fan until shutdown. Any other ideas?
Top of pagePrevious messageNext messageBottom of page Link to this message

Stimbrell
Posted on Monday, June 07, 2021 - 06:46 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

On later ECMs the second fan is set by a time delay not a temperature so someone may of set it to a long delay, it can be set as high as 255 seconds, 4.25 minutes.
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Monday, June 07, 2021 - 10:33 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Would that setting be in Ecmdroid? The ecm I have hooked up is a brand new race ecm from IDS. Would they have set a time delay?
Top of pagePrevious messageNext messageBottom of page Link to this message

Stimbrell
Posted on Tuesday, June 08, 2021 - 09:47 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I use Tunerpro to access that setting but as you say it is a new ecm from IDS I would not expect them to have done that. Normal setting is 75 seconds. Is it possible the ecm uses a different path to earth when the bike is running than it does for key off? in which case I would look at a bad earth connection. Good luck.

(Message edited by stimbrell on June 08, 2021)

(Message edited by stimbrell on June 08, 2021)
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Tuesday, June 08, 2021 - 09:58 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So I took the bike out last night Keeping a close eye on coolant temp and action from the fans. Coolant temp lingered around 180f while cruising and crept up continuously while sitting at lights. The right fan never came on while bike was running. Again kicking on immediately upon key off. I'm really feeling like I have exhausted all leads and I'm now considering just hooking up the right fan to a switch that will give it ground at my command. I'd really prefer not to go this route but I don't see a whole lot of other options to get this fan running when it's needed most. If anyone has any other thoughts or ideas I'd love to hear them before I cobble up this clean bike. TIA
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Tuesday, June 08, 2021 - 08:23 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks stimbrell. I've been trying to locate grounds off the ecm for some time now. I'm having trouble as all that wiring that comes off the ecm is immediately tucked away up between the frame and motor. I'll have to go back to the wiring manual and see if I can locate them. Hard to believe that a bad ground to the ecm would only be causing one fan to malfunction but I suppose I shouldn't rule it out. Thanks for the help.
Top of pagePrevious messageNext messageBottom of page Link to this message

Stevel
Posted on Wednesday, June 09, 2021 - 01:27 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Send the ECU back to IDS. They will sort it out.
Top of pagePrevious messageNext messageBottom of page Link to this message

Coastrambler
Posted on Wednesday, June 09, 2021 - 03:00 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Tried putting a fan on a switch. Kinda worked. ECM noted that fan was no longer connected to it. Something to keep in mind.
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Wednesday, June 09, 2021 - 12:12 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Stevel, thanks for that recommendation. I just contacted ids and spoke over the phone with someone. I described my issue and what I've done. He said that it all sounds like it's functioning properly. Claims that the right fan will kick on if the bike begins to overheat. He said that the fan kicking on is based on several variables including battery voltage (recharge strength from the stator) and engine temp. He said I have nothing to worry about. Once again thank you for the recommendation. I likely would have ended up cobbling a switch in if I wouldn't have made that call. Thank you to everyone who gave me feedback on this thread. You all are appreciated. I am relieved.
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Thursday, June 10, 2021 - 08:17 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Have same problem with left cooling fan . Never seems to come on . Grounded fan at ecu & comes on .kinda hard to check when driving but no overheating. Does get warm in stop & go traffic
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Thursday, June 10, 2021 - 11:37 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

1125rz what year and ecm? How warm does it get and in what ambient temperature? Does that fan kick on at key off cooling interval?

(Message edited by Dr. Octagon on June 10, 2021)
Top of pagePrevious messageNext messageBottom of page Link to this message

Coastrambler
Posted on Thursday, June 10, 2021 - 11:42 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Left fan wouldn't come on on mine. Removed it and tested it. Seemed ok. Put it back in and problem remained. Have now replaced that fan with a new one. Works great now. I believe left and right fans are the same. Got mine on eBay.
Top of pagePrevious messageNext messageBottom of page Link to this message

Dr_octagon
Posted on Friday, June 11, 2021 - 12:05 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Coastrambler was it coming on at key off or not at all before you replaced it?
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Friday, June 11, 2021 - 02:44 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

08 ecu . Left fan never comes on only right . It will get to 190 at stop 75-80 ambient temperature. Will check resistance of both fans when I get the chance to see if has major difference .
Might have too much resistance for ecu to ground out but works fine with power probe grounding
Top of pagePrevious messageNext messageBottom of page Link to this message

Coastrambler
Posted on Friday, June 11, 2021 - 04:45 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Left fan wouldn't come on at all. Fan out and connected to battery it worked. On a metered power supply it was kinda high draw. With new fan they both work.
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Friday, June 11, 2021 - 07:48 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Ty . Got new fan on order.will let you know if works when I get it
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration