G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » EBR Forum » 2014 Break in, Fuel injection issue? « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Sunday, April 21, 2019 - 07:48 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

2014 SX had 2 miles on the ODO a month ago, just coming up on 600 miles now. Obviously bike just sat for 4-5 years, I sucked old gas out of tank, put in new before I started riding it. Suspect an injector issue, no CEL, consistent mid, upper 30s MPG, sooty exhaust tip (Bike 100% stock) Can I get a clue visually? What should I be looking at, doing?
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Sunday, April 21, 2019 - 07:54 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Bike runs "pretty good", some catches hesitation off idle, not show stopping just not "perfect". I do have the TC set high (13) yet lots of sand on the roads yet. So that may be some of the "glitches".
Top of pagePrevious messageNext messageBottom of page Link to this message

Hughlysses
Posted on Sunday, April 21, 2019 - 08:06 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Doesnít sound like itís necessarily an issue. Iíd try backing down the TC to 6 or so and see if you notice a difference. Iíve never had mine set higher than 4 and it seems like the majority of riders turn it off.
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Sunday, April 21, 2019 - 08:25 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

But I've already walked out the rear 5-6 times in corners....Dang we need a good downpour or two to wash the roads....
PS I changed oil at 60 miles (5 years old) put in 10-40, will change soon to 20-50, she's using..... :^(
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Sunday, April 21, 2019 - 08:44 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So far no ethanol, highest grade at the pump. Typically 91. Is mid to high 30's MPG normal? backroads riding up and down to 70-75MPH some 80's, mostly 4-5th lots of corners down to 2nd. Not wacking the throttle.
Top of pagePrevious messageNext messageBottom of page Link to this message

Twirlin
Posted on Sunday, April 21, 2019 - 10:48 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I average 36mpg.
Top of pagePrevious messageNext messageBottom of page Link to this message

Zacks
Posted on Sunday, April 21, 2019 - 12:36 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I get between 38-42 mpg on my RX.
5 year old stock tires may be hard. Could be the cause of it stepping out. Personally, I don't like the Diablos, but that's an opinion.
I run TC at 3.
If you think the TC is causing the occasional 'glitch', it will flash on the dash for a couple of seconds if activated. Take a peek when you think it's glitching.
Top of pagePrevious messageNext messageBottom of page Link to this message

1_mike
Posted on Sunday, April 21, 2019 - 12:55 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

NO...ethanol..? Where do you live?

I'd put three or four tankfulls of a good fuel injector thru it. It'll help make sure everything is clean.

The best I found was Red Line, but at least here in SoCal, it's not available any more. Next best I've found after trying a couple is the Lucas cleaner. You need about twice as much in the tank to equal the Red Line, but it works.
I've used a good cleaner for years in by bikes. After 100,000+ miles (on a few of my bikes), the ports are clean, the valves are clean, no injector spray problems.

Worth a try.

Mike
Top of pagePrevious messageNext messageBottom of page Link to this message

Shoggin
Posted on Sunday, April 21, 2019 - 12:56 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Since there was old gas already in the fuel lines and rail, you could still have sent some crappy gas through it.
Pull out the 3 injectors and have them cleaned?

Otherwise sounds good to me, and heck yes I'd buy new tires!
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Sunday, April 21, 2019 - 01:00 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Yeah tires are pretty good yet, good enough for my spring street riding. Just lots of fine sand from winter road salting yet. Yeah good call will add injector cleaner, I've been indoctrinated to use Techron. Wisconsin allows non ethanol premium here in the hinterlands.
Top of pagePrevious messageNext messageBottom of page Link to this message

Twirlin
Posted on Sunday, April 21, 2019 - 01:18 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I too, in southern Wisconsin, have no ethanol premium.
Top of pagePrevious messageNext messageBottom of page Link to this message

Skntpig
Posted on Monday, April 22, 2019 - 01:59 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Old tires, cold slick roads and TC on means bike will buck and knock itself off the power and probably buck some more.
Top of pagePrevious messageNext messageBottom of page Link to this message

Ggggary
Posted on Monday, April 22, 2019 - 03:42 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Dropped TC to 5 put in part of a bottle of Techron injector cleaner and rode. Seems better?? Cop suggested I use less throttle, (in writing) didn't try to explain I WAS being careful during break-in..... What I thought was oil consumption was side stand in a dip, dropped apparent oil level. Nearly to 600 on the ODO, so will change to 20-50 and cut and carefully inspect the old filter. Thanks for all the suggestions, comments
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration