G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » EBR Forum » 2000 X1 low RPM idle to 2k runs rough « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Pjmule
Posted on Monday, September 03, 2018 - 05:34 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Bike runs strong above 2k rpm but idle and slow riding it has popping and rough idle. Would race ecm help this ?
Top of pagePrevious messageNext messageBottom of page Link to this message

Hughlysses
Posted on Monday, September 03, 2018 - 06:27 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Dude, youíre WAY in the wrong sub-forum. Look for Old School Buell.

Sounds like it could be a vacuum leak, which is often caused by leaking seals at the intake manifold/cylinder head joints. Test it by spraying something like starting fluid or WD-40 at those joints. If the idle smooths out or speeds up, thatís your problem, and you need new seals.
Top of pagePrevious messageNext messageBottom of page Link to this message

Pjmule
Posted on Monday, September 03, 2018 - 08:23 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Yeah sorry, Old School is one click down. Thanks for the tip though.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration