G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Electrical - Battery, Charg Sys, Lights, Switches, Sensors & Guages » 2005 XB12R, dies suddenly, no codes. « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Blazinc5
Posted on Wednesday, May 10, 2017 - 02:41 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So, I have had this bike for a long time. and she still runs strong for 40K on the clock. (when she don't die) I have the race kit on it too. There isn't any riding scenario that sets it off either. It dies like no fuel or no spark. I did also hook up the ecm spy and couldn't find anything. All diagnostics checked out. I had a while back took it to the local HD shop and they couldn't figure it out either.. As usual they couldn't duplicate the problem. The only good comment the mechanic made was that it runs exceptionaly strong and I have taken great care of her.
Just recently, I was thinking the fuel pump may be the culprit so I changed it out with new filter and regulator. Nope, still dies on me with no explanation. It usually takes a min or two but it will fire back up. flip the key, flip the kill switch a few times, and usually will start up again. I tried a few searches and keep coming back up with 3 likely areas. Bank angle sensor/ cam position sensor/ ECM. I am leaning towards the cam sensor or the bank angle. As I am not loosing any lights or other functions. The engine just stops. I pulled the nose off and checked wires and connections. I also took the bank angle sensor loose tipped it to kill the bike. Was very similar to how the engine died out. But it seems to work properly. And even when I unplugged it, the bike still ran,, (With a code on the display). I may ride a bit this weekend with it unplugged, just to see if it cuts out on me.
I have done some searches on cam position sensor replacement and so far I have not been able to find much info online. Any ideas to my dilemma?

(Message edited by Blazinc5 on May 10, 2017)
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration