G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Troubleshooting (Poor Starting/Running/Handling/Ride Issues) » Buell blast primary chain noise « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Madman7707
Posted on Wednesday, July 13, 2016 - 06:20 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

my 2009 buell blast was a riders edge bike that had 843 miles on it when i got it. has bout 1400 now. it runs good have been to 80 on it with power to spare. but when holding steady speed the primary noise will drive u nuts. the sound disappears if u let off the throttle, and lessens to almost gone when hammered down is there any thing i can do to help this noise die down
Top of pagePrevious messageNext messageBottom of page Link to this message

Cvc
Posted on Tuesday, April 18, 2017 - 10:02 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Check primary adjustment then if right GET THE COVER OFF had a low miles blast in the past made similar noises then vibration between on and off throttle the nut on the crankshaft was coming loose stripped the end of the crank. On another blast the rear wheel bearings gave me a strange surge at speed when steady felt like I lost spark for less than one second then back to normal if I accelerated or even held steady several members here suggested a tight primary , raise back of bike in neutral spin wheel might need stethoscope at axle , don't pressure wash bearings gets water in them oops rear blast bearings are the same as GEO Metro outer bearings at any auto parts store
Top of pagePrevious messageNext messageBottom of page Link to this message

Cvc
Posted on Tuesday, April 18, 2017 - 10:04 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Did not realize this was so old hope he got ths fixed long ago
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration