G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Troubleshooting (Poor Starting/Running/Handling/Ride Issues) » 09 XB12SCG Rough Idle/Stalling/backfiring when up to temp « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Rwelshman
Posted on Sunday, June 05, 2016 - 03:25 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I have a 2009 XB12SCG with EBR Race ECM with Jardine Exhaust

bike runs fine when it is initially started but will run like crap once it is up to temp. it almost sounds like a cyclinder drops out. bike runs fine when on the highway and only starts giving issues when in traffic (stop and go).

I have tried replacing the spark plugs but it did not help. I have also tried reinstalling the stock ECM but the bike will perform the same way. I have also tried doing a TPS reset which doesn't help aswell.

here is a couple vids of how it sounds
https://www.youtube.com/watch?v=FVVJ3Cy-OjE

https://www.youtube.com/watch?v=KWjaacQfT6Q
Top of pagePrevious messageNext messageBottom of page Link to this message

Gabby_duck
Posted on Sunday, June 05, 2016 - 06:38 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I would start with the IAC (idle air control)
Two allen screws hold in place.remove and clean the ports.
Top of pagePrevious messageNext messageBottom of page Link to this message

Rwelshman
Posted on Friday, June 10, 2016 - 06:22 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

thanks for the advice

Think I may have fixed the issue. I pulled and cleaned the IAC sensor ( there was a little bit of oil built up on tip not sure if that is normal?). also when I originally installed the jardine exhaust I unplugged the exhaust valve actuator and just left the connector under the cover so I decided to remount and plug it back in. are you suppose to remove it completely or leave it alone??. also did another TPS reset and IAT reset and drove the bike for 30-40 min. when i got home and let the bike idle for another few minutes with no issues
Top of pagePrevious messageNext messageBottom of page Link to this message

Gabby_duck
Posted on Friday, June 10, 2016 - 08:27 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

IAT ( inlet air temperature can't be reset.) Does jardine have the interactive exhaust? IAC and the ports must be clean. With a clean lint free cloth spray the cloth with throttle body cleaner then clean both sides of throttle butterfly.
Top of pagePrevious messageNext messageBottom of page Link to this message

Rwelshman
Posted on Friday, June 10, 2016 - 09:09 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

what i meant was after doing the TPS reset I let the bike idle for 10 minutes to do an IAC averaging re-set

(followed directions that came with EBR race ECM)


The Jardine does not have an interactive exhaust
Top of pagePrevious messageNext messageBottom of page Link to this message

Gabby_duck
Posted on Friday, June 10, 2016 - 09:18 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Copy that glad everything seems to be working
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration