G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Troubleshooting (Poor Starting/Running/Handling/Ride Issues) » Wont spark ddfi not loading « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Prnglz357
Posted on Saturday, March 12, 2016 - 02:12 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

thought it was the starter relay, but still wont spark. no loading sound from ddfi, everything else works, just wont start.

2002 XI White Lightning
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Monday, March 14, 2016 - 01:59 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Not sure I understand. There is no sound from the 'ddfi loading'. There should be a 'whirring' sound as the fuel pump builds up pressure in the fuel line/fuel rail. It could be the ignition relay is not making contact, so no power to the ignition related items. Ignition fuse good? 12V+ from the battery? Has the sidestand switch been bypassed?

If the engine turns over but won't fire, replace the ignition relay first, then look elsewhere. Pls let us know how it goes.

Hope this helps, Dave
Top of pagePrevious messageNext messageBottom of page Link to this message

Froggy
Posted on Monday, March 14, 2016 - 02:19 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

If you are not hearing the fuel pump, check and see if you are getting the "check engine" light after turning the kill switch to run. If you are not getting a CEL, that means the ECM is not powering up, which is why the pump isn't running.
Top of pagePrevious messageNext messageBottom of page Link to this message

Gabby_duck
Posted on Saturday, March 19, 2016 - 01:54 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Check fuses
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration