G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Electrical - Battery, Charg Sys, Lights, Switches, Sensors & Guages » Neutral Sensor problem ('05 Blast) « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Magus10112
Posted on Monday, October 06, 2014 - 04:54 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hey all,

I think I've got a problem with my Neutral Sensor. The dash doesn't show I'm in Neutral when I am, and if I let off the clutch while in Neutral the bike dies.

I'd like to fix this problem myself since I know how dealerships can handle electrical issues, but have any of you worked on an issue like this before? I'm not even sure where I should start looking on the bike (I have no service manual for this bike).

Any help would be more than appreciated,

Thank you!
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Tuesday, October 07, 2014 - 08:27 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

First, get the service manual. I expect you already know that.

Unplug the wire to the neutral switch. With the key on, ground the wire to the frame/motor. The neutral light should come on. If it does, everything up to the switch is good.

With a multimeter on ohms, and the bike in neutral, check for continuity. You should have a complete circuit from the wire connector to ground. If not, the switch is bad, and needs to be replaced.

Hope this helps, Dave
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration