G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Electrical - Battery, Charg Sys, Lights, Switches, Sensors & Guages » Cracked grey ecm connector caused CEL code 13,44 & 43 « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Atc_no_more
Posted on Monday, September 15, 2014 - 07:25 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

After checking a bunch of items on my intermittently poor running 2008 Uly, I found the source of the problem. The grey connector on the ecm is cracked at a seam. Priced it at the local dealership-$370. Can someone tell me where I might get an OEM replacement online at a better cost? And the service manual says "it will be necessary to download the correct calibration, using DIGITAL TECHNICIAN..." is there a tread that explains this or offers options on ways to do this. I've seen the terms "reflash" and "ecm mapping" on some quickly reviewed threads, but this area of repair is new to me. Thanks.}
Top of pagePrevious messageNext messageBottom of page Link to this message

Froggy
Posted on Monday, September 15, 2014 - 08:04 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

You are better off getting the Race ECM for Stock mufflers from Erik Buell Racing. It is cheaper, pre programmed, plug and play, and actually will make your bike run better than it did with the stock ECM. Smoother acceleration, easier starts, smoother idle, little more power, and better fuel economy.

http://www.erikbuellracing.com/store/models/xb12/x b12-preprogrammed-ecm.html

Once you do get a new ECM, don't install it in the factory location or you will have the same issue down the road. Do a search on here for ECM relocation, there are plenty of threads with suggestions and pictures.
Top of pagePrevious messageNext messageBottom of page Link to this message

Atc_no_more
Posted on Monday, September 15, 2014 - 08:52 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks Froggy.
You mean just plug it in and it's ready to go? That would be great!
I did see that relocation thread and will do that.
Top of pagePrevious messageNext messageBottom of page Link to this message

Atc_no_more
Posted on Monday, September 15, 2014 - 08:54 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

And with a TPS reset too.
Top of pagePrevious messageNext messageBottom of page Link to this message

Reepicheep
Posted on Tuesday, September 16, 2014 - 07:46 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

The stock ECM is often fixable as well. It isn't rocket science, but it does have to be done carefully.
Top of pagePrevious messageNext messageBottom of page Link to this message

Xbimmer
Posted on Tuesday, September 16, 2014 - 09:58 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

^^^ Yes, it is fixable. My original 06 ECM failed, replaced it with a 07. 07 started failing, opened up and fixed the 06, put it back in. Recently opened up the 07, the connector joints are failing there too. See my pics here:
http://www.badweatherbikers.com/buell/messages/142 838/747295.html?1410827809

(Message edited by xbimmer on September 16, 2014)
Top of pagePrevious messageNext messageBottom of page Link to this message

Atc_no_more
Posted on Thursday, October 02, 2014 - 12:20 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Installed and relocated a new EBR ecm. The Uly is running like the bike I used to know and enjoy so much. And the different fan programing is a big improvement. FYI, the bike had about 24,000 miles on it when it "cracked up at the seams".

(Message edited by ATC_NO_MORE on October 02, 2014)
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration