G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Electrical - Battery, Charg Sys, Lights, Switches, Sensors & Guages » '05 XB9SX threw CODE 16, Battery voltage >17V « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Arqueware
Posted on Monday, June 23, 2014 - 01:37 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)


MegaLog View of ECM data for 6.20.2014

.
.
.
One evening, I observed the headlights dimming at ~5500rpm. The following morning the bike stalled, but recovered sufficiently to continue. I reckon that's when the code was thrown. After reading a load of posts, I'm presuming this is a faulty VR. I'll grab a used VR from Ebay to verify.
I checked the 77 connector, and did not see any melting or carbon deposits. What VR (part #) do I get to replace? Is any H-D VR compatible as a drop-in? e.g. a Sportster VR ?
I do recall the frame being exceptionally hot the day prior to getting the CEL CODE 16. Since the stock VR dumps voltage to ground, could that have been the cause of the perceived heat from the frame?
The flat part of the Battery voltage graph (in white) is a reading of 14.4V, and the dips read around 12V. The max voltage is 17.5. It was running well enough, and no blown lights yet, but I've parked it until issue is resolved.

Grateful to these boards for latter-day Buellers
(Message edited by arqueware on June 23, 2014)

(Message edited by arqueware on June 23, 2014)

(Message edited by arqueware on June 23, 2014)

(Message edited by arqueware on June 23, 2014)
Top of pagePrevious messageNext messageBottom of page Link to this message

Froggy
Posted on Monday, June 23, 2014 - 02:00 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Quincy, welcome to the board. That is an excellent use of Megalog Viewer and like your research concludes, your voltage regulator has likely failed.

All 03-07 XBs use the same regulator, that will plug and play install with no modification. It is possible the 77 connector will be different, as some bikes that had the VR replaced have the new version of the connector. The new connector can be retrofitted or you can just cut and splice if you desire. A brand new OEM regulator is $162, but your replacement used one is likely good enough (assuming you bought the correct one)
http://americansportbike.com/newdir/Item/17307

There are aftermarket options which require a little bit of effort to install, like the FH020AA from roadstercycle.com

The Sportster charging system is different and not compatible.
Top of pagePrevious messageNext messageBottom of page Link to this message

Arqueware
Posted on Monday, June 23, 2014 - 02:26 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Froggy, thanks for the confirmation and answers. (BTW, I attended WCSU for undergrad)

If ground is the reference voltage, it makes sense that a dip to ~12V might be interpreted by the ECM as a low voltage condition (voltage spread of 5V).

The ECM interface is a MUST HAVE, otherwise, you're ambling in the dark, grasping at vague symptoms. Made one for $25

(Message edited by arqueware on June 23, 2014)
Top of pagePrevious messageNext messageBottom of page Link to this message

Arqueware
Posted on Monday, July 07, 2014 - 11:17 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)


post-VR & battery replacement


Replaced the VR and battery; voltage graph is MUCH cleaner with batter voltage ranging from 13.3V - 15V

(Message edited by arqueware on July 07, 2014)
Top of pagePrevious messageNext messageBottom of page Link to this message

Froggy
Posted on Monday, July 07, 2014 - 11:40 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Beautiful!
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration