G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Knowledge Vault (tech, parts, apparel, & accessories topics) » Electrical - Battery, Charg Sys, Lights, Switches, Sensors & Guages » Confusing ignition fuse/ ECM problem? « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Bultaco32
Posted on Friday, June 07, 2013 - 04:37 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I have a 06 xb12x. It blows the ignition fuse as I ride to work in the same place every day. As I'm taking off from a traffic light about an 1/8 mile from work, it blows. If I put a new fuse in, it will blow as soon as I take off (around 5 mph). After I let the bike sit all day at work I can ride it home till Iím about an 1/8 of a mile from my house and it will blow. It only does it when the bike is hot and riding about 6 miles in city traffic. This all started when I put a D&D exhaust with a TFI tuning box on my bike. The first 1,500 miles every thing worked great but then I started to note the RPM gauge jumping around. It never impacted the bike. It would start and run great. I read in one of the pages here that this was an indication of a bad ECM. I just bought a EBR ECM for a D&D exhaust and removed the TFI box. I have not put the new ECM in yet. Iím scared this fuse thing might hurt my new ECM. Can the ECM or TFI box cause this ignition fuse problem or is this a different problem. I also think the ECM was bad because it would put out a new code about every week. From this Issue, I have replaced the fuel pump, O2 sensor, voltage regulator, and lean angle sensor. After all this the light would stay on and the code was for the O2 sensor. I then put another new O2 sensor in and replaced the exhaust gaskets. I also cleared the codes after every repair. Thank you and any help would be great. I have been looking at homes that are about an 1/8 of a mile closer to my work just encase I donít get the bike fixed.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration