G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » XBoard » Xb12 2007 not running right « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Pontlee77
Posted on Saturday, February 25, 2017 - 07:52 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hello, I'm helping out with an xb12s, the bike was running not to good it was taken to a mechanic and don't know what was done with the electronics that bike stop running, I went and used ecm spy put new race maps (bike has k&n air filter and race exhaust), then adjusted the TPS while hot and it seemed to work well, then the mechanic did a 5 minute runnin fifth gear at steady 3000 revs. All ok so far, now they called me and the rpm were surging, did a resent of tps but wouldent stay stable they would go down with no reason, what do people suggest trotthe body leak? Bad gas pump?
I'm a bit lost because I don't see any evident reason.

Thanks.
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Saturday, February 25, 2017 - 11:37 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Surging and an unstable idle is usually a symptom of a lean condition; i.e. an air leak. So first check the intake manifold to head gaskets. If not successful, move on to partially clogged or leaking injectors, possible leaking injector O rings, ect.

Hope this helps, Dave
Top of pagePrevious messageNext messageBottom of page Link to this message

Pontlee77
Posted on Saturday, February 25, 2017 - 11:50 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks, over the week I'll go to the mechanic and see if it can be sorted out.
Top of pagePrevious messageNext messageBottom of page Link to this message

Pontlee77
Posted on Friday, March 03, 2017 - 10:52 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Seems the TB has a crack as we put new gaskets made sure they were well in place after putting all back together and doing a TPS reset, it would not hold stable rpms, we sprayed. Some carb cleaner and revs went up, we discovered a nearly invisible crack, at the right side were the T27 screw is. First time I've seen this.
Top of pagePrevious messageNext messageBottom of page Link to this message

Phelan
Posted on Saturday, March 04, 2017 - 11:53 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Wow, crazy! I've yet to see that as well. I have a few XB12 throttle bodies if you want to save $$$ over new.
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Sunday, March 05, 2017 - 11:07 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Glad you found it. Definitely a weird one. Good on ya!
Top of pagePrevious messageNext messageBottom of page Link to this message

Natexlh1000
Posted on Monday, March 06, 2017 - 10:46 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

That is a weird one. If it were mine and the crack was teeny, I would be tempted to JB weld it.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration