G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » XBoard » '08 Xb12 running real rough « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Emptychambers
Posted on Tuesday, September 13, 2016 - 03:16 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Okay got this bike and it sat for a bit while I ordered parts for it. Starts runs, rides. Occasionally will die when at a stop with clutch in, or even in neutral.occasionally Coughs through the airbox when throttle is biped downshifting.

K&N, Ebr race ecm, drummer SS. 35k miles.

Low speed(under 3000) coughing, stumbling. Over that it runs okay, but with hard throttle it almost sounds like it's hitting a limiter. Stutter and eventually pulls through but clearly isn't running as well as my other XBs have. No codes. No longer idles at 2k on start up.

Was planning on resetting tps (shouldn't cause this), clean the K&N, and checking for intake seals. Basically I'm assuming I did something to it myself.
What should I look for? Seemed to run great at the test ride so it can't be anything major. Has new gas.

(Message edited by Emptychambers on September 13, 2016)

(Message edited by Emptychambers on September 13, 2016)
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Tuesday, September 13, 2016 - 04:22 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

TPS reset won't hurt. The key may be in the 'it sat for a bit'. The symptoms seem to be pointing towards a lack of fuel/poor fueling. Check the front spark plug and look for signs of a rich mixture. Counterintuitive I know, but partially clogged and /or leaking fuel injectors will spray liquid fuel, instead of a fuel mist, causing lean running but a rich mixture. Something to consider if the other things you plan to do don't solve the problem.

Hope this helps, Dave
Top of pagePrevious messageNext messageBottom of page Link to this message

Emptychambers
Posted on Tuesday, September 13, 2016 - 04:46 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Dave, thanks for your input. I agree, 8t feels more like a tuning issue than anything else. I thought that I had possibly adjusted the clutch incorrectly, but it would still Rev freely on the highway if that were the case.

I got lazy and switched only the front plug earlier thinking it was fouled due to running on only one cylinder. I hadn't bought a blast, so this was problematic . Simple case of fuel injector plug being loose.

I'll have to go back in and double check all sensors. Anything anyone can think of that specifically would cause these problems. I hate to do multiple things trying to track down a singular issue. Can't ever figure out what was causing it ..
Top of pagePrevious messageNext messageBottom of page Link to this message

Natexlh1000
Posted on Tuesday, September 13, 2016 - 10:02 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

My 2008 was running like total crap with popping out the intake and incapable of maintaining idle RPM.
I opened the ECU and resoldered the connectors thinking they were loose but it did nothing. I put an oscilloscope on the timing pickup in front of the engine and it looked fine too.
I finally bit the bullet and got the IDS $300 computer.
Fixed it.
Runs better than it ever did since new.

Mine was acting like the timing was wrong.
Like as if the points were set to the wrong gap on one jug if that makes sense to you.

Happy hunting. Check the cheap/easy stuff first.
Top of pagePrevious messageNext messageBottom of page Link to this message

Phelan
Posted on Tuesday, September 13, 2016 - 11:39 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

An 08-10 has a super easy TPS reset. Always try that first.

Set the run/stop switch to run

turn ignition to on position

with engine off, rotate throttle from its closed position to WOT position and back to closed position 3 times, with a 1 second pause at each closed and WOT position.

then cycle the key off and then back on.
Top of pagePrevious messageNext messageBottom of page Link to this message

Akbuell
Posted on Wednesday, September 14, 2016 - 09:28 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Along with the TPS, there is a quick check to see if an injector is leaking.

Take off the air box cover and the air filter so you can see into the intake manifold. Turn the key on for 2 seconds, then off for 2 seconds. Repeat 5 times. Then hold the throttle wide open and look into the intake manifold. Any evidence of raw fuel means leaking injector(s).

Hope this helps, Dave
Top of pagePrevious messageNext messageBottom of page Link to this message

Vrptstyly
Posted on Monday, October 17, 2016 - 06:00 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Hey Nate did you buy the IDS with their software? I have an IDS now on my 08 and still a bit rough in places. Need to investigate a little deeper.
Top of pagePrevious messageNext messageBottom of page Link to this message

Natexlh1000
Posted on Friday, October 21, 2016 - 12:14 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

I bought the IDS "race use only" ECU with the stock muffler and K&N filter option.

Zero the TPS again when the engine is warmed up. They do change just a little with temperature.
Top of pagePrevious messageNext messageBottom of page Link to this message

Vrptstyly
Posted on Sunday, October 23, 2016 - 04:14 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thanks! Yea I'll look into it. Was looking for some feedback on there tuning software.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration