G oog le Buell 1125R Forum | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » 1125R Superbike Board » Instrument cluster replacement « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Wednesday, May 08, 2019 - 07:53 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Have to change my instrument cluster due to tach reading anywhere from 500-1500 higher than normal(yes itís not at zero when the bike is turned off) anyone know why no mileage reflash is not required from dealer?
Top of pagePrevious messageNext messageBottom of page Link to this message

Oldog
Posted on Wednesday, May 08, 2019 - 01:13 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

the pointers slip on the shafts, several folks have opened the clusters and carefully
re-set the pointers on the shafts.

YMMV
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Wednesday, May 08, 2019 - 01:56 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Think itís more than that . Sometimes it reads normal , and when it is Reading off , when ignition is shut off it stays anywhere from 500-1500 higher (instead of zero) & returns to normal after key cycle
Top of pagePrevious messageNext messageBottom of page Link to this message

Panshovevo
Posted on Thursday, May 09, 2019 - 01:27 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

No mileage reflash is required when installing a new Intrument Cluster (IC) because after 30 minutes of powered connection, the ECM and IC ďmateĒ electronically and the ECM sets the accumulated mileage on the IC.

In the case of a previously used IC, it will display the mileage on the bike it was removed from.
Top of pagePrevious messageNext messageBottom of page Link to this message

1125rz
Posted on Saturday, May 11, 2019 - 03:16 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Ty . Just changed it . And after 30 min had had original mileage . New cluster has shift position indicator , old one didnt
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration