G oog le Buell 1125R Forum | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » 1125R Superbike Board » HELP - 1125R won't build oil pressure after oil change « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Buellster17
Posted on Friday, June 15, 2018 - 02:05 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

My 2009 1125R won't build oil pressure after oil change. I used the hiflo 564 filter, 3.0 quarts Mobil 1 vtwin oil, drained from left to right, new crush washers... By the book. I have run the bike for a few minutes and the oil light stays on, loud mechanical chatter, something is not right. I even tried rocking the bike forward and back, left and right, no change.


This is my second 1125R to make this sounds and I'm worked my engine is about to seize. Please Help.
Top of pagePrevious messageNext messageBottom of page Link to this message

Blower1
Posted on Friday, June 15, 2018 - 05:39 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Did you put the oil filter in on right way?
Top of pagePrevious messageNext messageBottom of page Link to this message

Buellster17
Posted on Friday, June 15, 2018 - 09:06 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Yes, only one way to install the filter.
Top of pagePrevious messageNext messageBottom of page Link to this message

Oldog
Posted on Friday, June 15, 2018 - 02:04 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

PLEASE POST INFO ON THE OIL FILTER
Top of pagePrevious messageNext messageBottom of page Link to this message

Willmrx
Posted on Friday, June 15, 2018 - 11:04 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Check the oil screen and see if there is anything in it. If there is,it might give you a clue of what might be going on.
Top of pagePrevious messageNext messageBottom of page Link to this message

Buellster17
Posted on Saturday, June 16, 2018 - 12:12 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Much to my dismay, the filter was backwards.

The Arizona heat got to my head. Thank you all for helping another rider out.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration