G oog le Buell 1125R Forum | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » 1125R Superbike Board » (Help) - replaced ECM and Instrument cluster « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Sprintst
Posted on Friday, September 02, 2016 - 08:28 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So it was service day. New exhaust, which meant new ecm, and new speedo, since it was messed up again

I got the 30 minute counter, ran that out, and it just seemed to reset. It's in the "SERVICE NOW" mode, won't track miles, won't go into the setup menu

You can't replace both??

I could hook up the stock ecm and turn it on for 30 minutes, if that would sync, then put the new ecm in. Certainly can run it with the stock ecm, too lean with RT-3 exhaust

Doing the old speedo would be more problematic, but possible....

any thoughts?
Top of pagePrevious messageNext messageBottom of page Link to this message

D_adams
Posted on Friday, September 02, 2016 - 08:46 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Wow, that showed up quick. What happened with the speedo? Might it work well enough to sync with the ecm temporarily, then change it out?
Top of pagePrevious messageNext messageBottom of page Link to this message

Sprintst
Posted on Friday, September 02, 2016 - 10:56 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Speedo slipped the tach needle. I fixed it, but the heat killed it again a few weeks ago.

Really prefer not to tear it down again, but can if I have to.

The RT-3 is pretty impressive. Install was easy, though it seems to point at the tire a bit. I'll be doing a post it soon.
Top of pagePrevious messageNext messageBottom of page Link to this message

Sprintst
Posted on Saturday, September 03, 2016 - 10:14 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So this is pretty funny. Since I did the new ECM and speedo at the same time, it wouldn't sync the mileage.

I installed the original ECM, but ended up with the World's Highest Mileage Buell 1125R!!

ROFL

« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration