G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile


Buell Forum » THUMPer Forum » Buell Blast Thumper Knowledge Vault » Ignition, Battery, Charging System - Electronic Trouble shooting « Previous Next »

http://www.c5ignitions.com/motorcycle-ignitions.ht ml
For your stock and performance ignition needs!
EZ


A good step by step process for troubleshooting your electrical system:
http://www.badweatherbikers.com/buell/messages/3842/54010.html?1107789974

To advance the timing, you want to rotate the ignition module clockwise (as you are looking at it). If you advance it too far though, your motor will start pinging under load- which is NOT good ! You then NEED to back off or retard it some- until the pinging stops, this will be a counterclockwise rotation to retard the timing. I hope that helps. Advancing the timing increases the idle speed, retarding decreases idle speed.

http://www.youtube.com/watch?v=vCBtfz0toRw&feature=player_embedded


Pro - Series Ignition instructions:

application/pdf
SEIpg1.pdf (117.0 k)

application/pdf
SEIpg2.pdf (130.1 k)

application/pdf
SEIpg3.pdf (91.9 k)

application/pdf
SEIpg4.pdf (84.3 k)

application/pdf
SEIpg5.pdf (90.2 k)



Twin Tech 1005 Ignition - Buell® Blast

If you require a programmable aftermarket ignition for racing the Buell® Blast, we have the solution. You can use our Model 1005 Race version that mounts in the nose cone in place of the Blast module. You must replace the original equipment coil with our mini coil (P/N 2006) that has 3 ohm primary resistance. You will also require our timing rotor (P/N 18004) and VOES switch (P/N 18010). Minor modifications are required to re-index the timing rotor and provide clearance in the Blast timing cover. Please refer to our Buell® Blast Tech Note for more details.

application/pdf
Blast_Tech_Note.pdf (114.7 k)


As far as the twin timing cup, I'm pretty sure I followed the directions from Twin Tech on making a cup to use their ignition on the Blast (posted in the ignition module section). The second hole is where it would be if the Blast was a twin XL or XB and would fire on the missing cylinder compression stroke. Static timing is still the same, but you'll need to use a 'dial back' timing light and use the TDC flywheel notch to verify timing. The 2 dots previously used will now show full advance! Its the budget way to get a good ignition and 7500 rpms. The SE module was about $120 new!
SE module part # is 32969-98 and 32971-98 for the 7500 rpm limit modules. (They also sell 6800rpm modules, but why bother?) One is for the 883, the other for the 1200. You'll get better performance with either, but which advance curve is better I dont know. They run about $120 new, but watch e-bay for deals since they are discontinued.
Just about any Sportster 'nose cone' ignition will bolt in without much hassle. So there are some other SE modules that will probably work, including some selectable modules, but they arent fully adjustable like the Blast/XL SE module is (and they cost more).
To run these twin modules you'll need a different coil as the Blast uses a .5 ohm coil, the other modules use a 3ohm coil (check to be sure). The .5ohm will work, but you may damage the module, eventually.
You'll also need to run a modified twin timing cup otherwise your advance curve will run up at 1/2 rpms and you'll have a 15000 rpm limit (thats bad).
You'll also lose the TPS, but you can hook up a VOES or run nothing (the ignition defaults to WOT running without a TPS or VOES).
You'll also lose the auto enrichener (electric choke). I havent verified this, but you may be able to hard wire the auto enrichener to a switched (on with ignition) 12v power supply or a manual switch. Still waiting on verification whether the auto enrichener gets power all the time or only for the first 5-10 minutes of running. Or run a very easy to find twin CV carb.

Its not nearly as complicated as it sounds, but it gives you the choice of spending $300 on an aftermarket ignition or much less on a Screaming Eagle ignition. Both will probably need the above modifications to make them work properly since only the SE Blast/XL programmable ignition 'bolts right on' (and is very discontinued: ().




Buell® Blast
If you require a programmable aftermarket ignition for the Buell® Blast, we have the solution. You can use our Model 1005 that mounts in the nose cone in place of the Blast module. You must replace the original equipment coil with our mini coil (P/N MINI-COIL) that has 3 ohm primary resistance. You will also require our timing rotor (P/N ROTOR-32402) and VOES switch (P/N VOES-KIT-MC7). Minor modifications are required to re-index the timing rotor and provide clearance in the Blast timing cover. Please refer to our Buell® Blast Tech Note for more details.


Clutch Switch Fix -
I was having some trouble with the safety switches and a dead starter button. Sometimes it would seem like it was the neutral switch, as shifting from neutral into gear and back again would sometimes energize the starter. Then other times it would seem like it was the side stand, because dropping the side stand or raising it would allow the starter to energize.

Well, It was neither. The culprit was the clutch switch. Apparently the clutch perch is tweaked a little because of the new bars I have installed, and as a result, the switch plunger was not fully extending unless the clutch lever was clamped hard into the grip. It only seemed like shifting the bike, or monkeying with the stand was helping; what was really happening was that I was changing my grip on the clutch lever slightly without realizing it...

I shaved 1/16th off the plastic plunger of the clutch switch, and bingo, problem solved...

Kick stand - cut twist and tape wires - done

Clutch Safety - Flip diode


application/msword
Blast static timing.doc (142.8 k)
application/msword
Blast static timing-alternate method.doc (66.0 k)

Start New Thread
  Thread Last Poster Posts Pages Last Post
Is a working battery needed to do a "diagnostic"?Crackhead03-21-17  03:44 pm
Tps questionAnthony026703-08-17  10:49 pm
2002 Blast wont start or idleGearheaderiko09-22-16  01:12 pm
All electrical power cuts off, then clicks back onT_rush07-01-16  06:47 pm
Spuradic starting and dyingEzblast20 02-25-16  04:57 am
Battery Issues46yeah11-09-15  01:47 pm
WTH did I do to the new statorKerryb10-06-15  07:35 pm
2006 Buell Blast. To what does this wire attach?Ezblast08-26-15  04:30 am
Trouble with first bikeEzblast16 07-23-15  03:43 am
Problem With Starter! Ezblast04-28-15  06:19 am
Ignition Issues - help for othersWyatte04-03-15  10:28 am
Blast Headlight Odd Problems to Not workingJohnglover12-15-14  09:20 pm
Headlight Replacement.Ezblast11-18-14  03:58 am
05 blast Neutral Sensor ProblemEzblast10-07-14  03:11 am
Taillight and turn signalsShine~on108-13-14  02:45 pm
Battery/Electrical ProblemsEzblast07-17-14  10:34 pm
A message of thanks and apperciationGearheaderiko05-29-14  04:28 pm
Blowing "system fuse"Ezblast11 05-30-14  02:35 am
Spark PlugEzblast11-20-15  02:12 am
Starter diode/ ignition diode problemsGearheaderiko04-04-14  03:53 pm
Cafe racer conversion....StumpedEzblast03-12-14  02:27 am
Starter Hard Grinding and Not StartingMgkoret10-09-13  03:10 pm
Lost my only key, you know where this is going...Ezblast10-27-13  11:54 pm
New Battery but Losing CHARGE!!! http://www.badweatherbikers.com/bu...Ezblast29 06-02-15  12:22 am
Horn issuesNimbly11-13-14  12:08 pm
I think it's the coil??Riverpirate02-10-13  01:58 pm
Signals and tail light not workingEzblast12-18-12  11:26 pm
02 Blast ignition module. Will this workEzblast12-12-12  04:48 pm
05' Ignition Fuse burning outEzblast08-19-12  07:03 pm
Battery LifeBuellistic07-08-12  10:38 am
Blast not blastingPsychologic305-28-12  08:47 am
Blast loses ALL powerEzblast11 07-08-12  02:49 pm
Timing is everythingGearheaderiko03-26-12  02:07 am
LED Turn Signals Making My Relay BuzzLostsurfer177110-07-12  12:45 pm
Starting issues...Ezblast11 04-15-12  01:52 pm
2001 Blast - Hard to cold startPegasus1903-25-12  05:58 pm
Battery QuestionBuellistic02-15-12  07:30 pm
Watts what?Johneblast12-19-11  08:11 am
No ElectricalNdrew07-26-11  08:18 pm
Accessory wire location?Xenox03-16-11  03:01 pm
Supplemental lighting for Blast?Gearheaderiko10-12-10  08:50 pm
Blinker IssueMeijerbrantm09-13-10  05:23 pm
Auto enricher wiring.Team_ruthless08-18-10  01:06 pm
2000 Buell Blast Timing ProblemsGearheaderiko11 08-15-10  10:39 pm
Starter/transmission problems '00 BlastSwampy08-10-10  10:50 pm
Neutral LightEzblast07-29-10  06:32 pm
Charging a totally dead batterySwampy07-25-10  10:45 am
Setting timing for 515Gearheaderiko07-19-10  08:06 pm
Starting/electrical problemYurtos07-06-10  11:05 pm
Strange starting problems...(where do I start?)Gearheaderiko05-20-10  03:22 am
Trouble Replacing Stock IgnitionGearheaderiko04-21-10  10:49 am
hyper (quick) flasher on just one Hyper flasherEzblast04-17-10  05:29 pm
Horn & Turn Signals not working.Ezblast13 04-24-10  09:55 pm
Crane Cams Ignition ModuleEzblast13 03-27-10  11:06 pm
Timing from Hell!Ezblast03-01-10  11:33 pm
Blinkers won't stop! They get stuckGearheaderiko01-16-10  10:17 pm
Weird Starting ProblemsYttikcat11 03-07-10  06:13 pm
TPSJon02219106-16-16  11:06 pm
Automatic choke voltage readings?Texas_firebolt10-28-09  01:28 pm
Where's The Engine Ground ConnectionTyronewildman10-26-09  04:38 pm
Need an ignition module asap?Truthnexile18 03-09-10  11:17 pm
2001 Blast no spark but cranksGearheaderiko39 10-11-10  11:24 pm
Turns over but no start. Reuel12 09-06-09  04:59 pm
My bike randomly refuses to turn over, suddenly works after a coupl...Reuel09-07-09  02:04 pm
Would stator/regulator problem keep Blast from starting?Ezblast08-10-09  12:49 am
Neutral light stays onGearheaderiko08-15-13  05:44 pm
Bike won't startEzblast15 08-31-10  01:20 pm
Cold Start ProblemEzblast07-09-09  01:35 am
01 Blast runs good cold, sputters, misses and stalls hotGearheaderiko38 07-11-09  10:13 pm
Turnsignals and horn stopedReuel15 06-26-09  09:47 pm
Help!: Engine dies after 5-10 secondsSwampy06-10-09  01:00 am
Bad ignition module, back fireGearheaderiko59 03-24-11  10:36 pm
Switching highlight flash and horn button Ratsblast03-04-09  10:34 pm
Grounding out? And Carb?Wacker212333 02-14-09  08:54 pm
Spark plug wire keeps coming offGearheaderiko09-27-08  01:13 am
'02 Blast Won't StartReuel09-08-08  09:38 pm
Inconsistent starting on daughters blastReuel10 08-24-08  07:15 pm
Timing correct but won't run rightGearheaderiko07-19-08  02:21 am
Charging SystemSwampy17 04-21-10  09:32 pm
Throttle Position SensorGearheaderiko34 05-14-08  10:29 pm
Replacement BatteryMarksblast13 04-28-17  06:09 pm
Neutral light stays on and bike runs but backfires now and then...Ezblast05-23-15  01:20 am
Brake Light WoesMiss_doc13 11-10-08  09:13 pm
Losing PowerReuel04-16-09  09:28 pm
Starter switchLake_bueller08-17-05  03:41 pm
Newbie -- problem with starterAbtin210-24-05  02:12 pm
Bike runs with stand downNewblaster06-27-05  02:18 pm
Turns over but no spark.Buelltoys18 07-18-08  09:03 am
Neutral light flickeringJugallo9404-11-06  10:55 am
Tip sensorGearheaderiko04-24-06  10:03 am
Stator and Regulator CheckAllenbassin07-22-07  04:45 pm
Highbeam woes!Superthrob07-13-06  01:16 am
To those who have dominator headlightsSuper_single07-14-06  12:11 am
Two questions about turn signalsGearheaderiko07-14-06  09:32 pm
No start BlastEzblast12 11-18-09  01:00 am
Battery problems againBerkshire09-02-06  05:29 am
Neutral light is out and stand stalls the bike when downJlnance13 10-10-06  07:50 am
Extra Blast KeysEzblast15 09-03-08  03:51 pm
Electrical Gremlins Gearheaderiko36 05-20-10  03:30 am
Ignition ModulesTruthnexile239 03-11-10  09:04 pm
Ignition coilGearheaderiko16 03-26-08  01:26 pm
Another Speedometer Sensor issue, any help appreciated!Gearheaderiko05-01-07  08:55 pm
Hard starting, but runs fineJoey07-14-07  08:06 pm
Hard starting - Engine hotGearheaderiko07-30-07  07:37 pm
HornWolffsoul10-01-07  02:42 pm
Won't start!Ezblast22 07-14-11  05:04 pm
Automatic choke/auto-enrichenerBoatwrenchv811 11-19-09  08:05 pm
Starts then dies. Reuel29 07-15-08  01:06 pm
Fuse blown no trun signalsCredo_pirata02-13-08  08:34 pm
Ignition steering lockBlastnyerass0107-23-08  12:14 am
Cold Iridium PlugsEvanj1105-05-12  10:51 pm
Where does your ignition module light go off?Gearheaderiko18 04-18-12  11:07 pm
Ignition timing help!Jetlee17 04-18-12  04:32 pm
Removing timer cover solutionGearheaderiko11 04-29-12  11:18 am
P3 not chargingEzblast08-13-15  05:13 am
Archive through March 21, 2015Ezblast30 03-21-15  03:51 am
Archive through October 28, 2009Bandito9030 10-28-09  02:09 am
Archive through September 12, 2008Ezblast30 09-12-08  05:36 pm
Archive through February 17, 2008Gearheaderiko31 02-17-08  02:41 pm
Archive through July 14, 2007Gearheaderiko30 07-14-07  01:37 am
Archive through March 22, 2007Swampy30 03-22-07  07:01 pm
Archive through January 28, 2007Ezblast30 01-28-07  01:25 am
Archive through September 18, 2006Ezblast30 09-18-06  04:11 pm
Archive through April 07, 2005Ezblast30 04-07-05  11:44 pm
Archive through June 21, 2004Buellkat30 06-21-04  10:02 pm
  Start New Thread        

Spark Plugs
10R12A
NGK DPR7ea-9 hot (not recommended)
NGK DPR8EA-9 medium
NGK DPR9EA-9 cool (equivalent to Buell 10R12)
DCPR same except socket size
Denso Irridium IXU01-27 (Notes: Do not use their recommended plug - it references back to the old 6R12 number that is too hot and was superceded to the 10R12. Also red locktight the ceramic and electrode together before installing, otherwise they will viberate loose. Their Racing plug plug IXU01-27 is the hot ticket and will suposedly last the life of the vehicle - I run it!)

Note: the Crane Cams "Fireball" HI-4 (Powerlink)Programmable
Ignition is the same thing as the Blast SE Ignition, and what HD/Screaming Eagle relabeled for
their own use. BTW- it's the Ignition that I've been running for a
while now.

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Chipmyers
Posted on Saturday, March 21, 2015 - 07:59 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

That's what I did. Worked fine. Did a little 15 mile ride today after work and all went well.

Thanks again for your help
Top of pagePrevious messageNext messageBottom of page Link to this message

Gearheaderiko
Posted on Sunday, March 22, 2015 - 11:43 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

From the "just in case" file: make sure the gasket sealer is rated for gasoline use. If it's not it will come apart and clog up the carb.
Top of pagePrevious messageNext messageBottom of page Link to this message

Chipmyers
Posted on Friday, April 03, 2015 - 12:18 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Troubles continue........
Last night the blast cut off on my wife, just DIED. No electrical at all. Tugging on the wires the ignition switch came apart. Melted plastic and some melted wires. Looked like toast, no pun intended.
Any ideas on a replacement? Nothing on Ebay and American Sport does not have a listing. Hoping to please the Blast Gods and get some divine guidance...

As usual, Thanks
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Saturday, April 04, 2015 - 03:59 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Loose front ground grounded and fried the ignition. Goes for that and clutch line. So check that as well. To replace it just order it from - https://shop.newcastlehd.com/https://shop.newcastlehd.com/
EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Chipmyers
Posted on Saturday, April 04, 2015 - 06:23 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Thank you
Top of pagePrevious messageNext messageBottom of page Link to this message

Chipmyers
Posted on Sunday, April 05, 2015 - 10:58 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

No luck. Found a second hand one @ TD Motorcycle in Denver though. This bike was wrecked and I patched together with all sorts of tape and bubble gum. I have found all sorts of kustom repairs.
I am gonna keep sorting them out and should have a brand new 15 year old motorcycle soon.
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Thursday, April 16, 2015 - 11:07 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

http://www.c5ignitions.com/motorcycle-ignitions.ht ml
For your stock and performance ignition needs!
EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Blueblast
Posted on Friday, April 17, 2015 - 12:04 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Awesome! Thanks EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Friday, April 17, 2015 - 12:14 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Since ignitions will be first on the parts kill list, I brought these guys up because first their ignition can be bolt on for stock configuration, and for modified motors they are willing to help there as well with raised rpm limits, custom curves, or even a programmable ignition. Their cost is explainable since a 80,000 volt coil and wire system also comes with the ignition package - making it about a little over 60 bucks over a stock ignition alone - if you can find one - lol
EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Vicenzajay
Posted on Sunday, April 19, 2015 - 11:00 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

So let's talk about the C5 ignition...

Is it simple plug-n-play? How much wiring work is needed?

Can we raise the RPM limit with it (just a bit) for a stock (stage 1) motor?

Same timing procedure as with stock ignition? (talking about static timing here)
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Monday, April 20, 2015 - 03:19 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

They have a plug in type that is pure plug and play with it already set for 6800 rpms - the highest a stock bike will go. I have a friend going with a custom one - with the tps adapter - two curves - 1st curve the SE 5 curve with 6800rpms, and second curve the SE 9 curve with the rpms set at 8000.
The guy who runs the company seems very sharp and flexible - give them a call and see what would be right for your set up.
EZ
Top of pagePrevious messageNext messageBottom of page Link to this message

Vicenzajay
Posted on Monday, April 20, 2015 - 06:56 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Sounds like the stock setup already gives us a small increase in RPM limit...which would be nice without having to incur much in the way of further work.

Speaking of work - how's the install - plop it in there and attach wires? Set timing and go?
Top of pagePrevious messageNext messageBottom of page Link to this message

Ezblast
Posted on Tuesday, April 21, 2015 - 05:04 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Give him a call, he installed it on both of his Blasts. He'll be able to answer any questions.
EZ
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration