G oog le BadWeB | Login/out | Topics | Search | Custodians | Register | Edit Profile

Buell Forum » Big, Bad & Dirty (Buell XB12X Ulysses Adventure Board) » Getting a click from turning bars to full lock « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Grand
Posted on Wednesday, October 03, 2018 - 11:04 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

As title, I'm getting a loud click when turning steering to full lock, right at the point where it reaches max turn on both sides. Has to be turned fully in other direction to reset and get noise again. Noise is strangely hard to pinpoint as it sounds like its coming from inside frame in front of fuel cap area. Tried holding cables still as they run past steering head to see if that stops it but no different.
Anyone else had this?
Top of pagePrevious messageNext messageBottom of page Link to this message

Ratbuell
Posted on Wednesday, October 03, 2018 - 11:23 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

How many miles on your neck bearings? Last time you checked their torque? Does your steering lock function properly (the keyed fork lock)?
Top of pagePrevious messageNext messageBottom of page Link to this message

Tootal
Posted on Thursday, October 04, 2018 - 10:07 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Try holding the front brake on and moving the bike forward and back and listen for a click. If you do it's the neck bearings.

You can try to readjust them, use the method in the service manual.
Top of pagePrevious messageNext messageBottom of page Link to this message

Grand
Posted on Friday, October 19, 2018 - 02:23 am:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Iíve been getting the clock sweep for quite a while too, thought I would look into this at same time.
Jacked front up, clock doesnít sweep then, still get clicking though. Torqued head bearings. Click stopped. Great I thought, dropped wheel back down , click returned.
Done 19000, steering lock works ok, donít get click when putting brake on.
Maybe it is the head bearings and I can ignore it until play can be felt or click comes with braking ?
Top of pagePrevious messageNext messageBottom of page Link to this message

Ourdee
Posted on Friday, October 26, 2018 - 08:18 pm:   Edit Post Delete Post View Post/Check IP Print Post    Move Post (Custodian/Admin Only) Ban Poster IP (Custodian/Admin only)

Try sitting on it.
Hold in front brake.
Rock back and forth.
If it clicks, jack up and push back and forth on forks.
« Previous Next »

Add Your Message Here
Post:
Bold text Italics Underline Create a hyperlink Insert a clipart image

Username: Posting Information:
This is a private posting area. Only registered users and custodians may post messages here.
Password:
Options: Post as "Anonymous" (Valid reason required. Abusers will be exposed. If unsure, ask.)
Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Tree View | Search | User List | Help/Instructions | Rules | Program Credits Administration